Problemas con impresoras en red

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas con impresoras en red

Mensaje por Alejandros85 el Jue Jun 02, 2016 7:44 pm

Buenos días amigos, me hice a la tarea de hacer 2 rutinas para imprimir, solamente dando los 2 puntos de la ventana de lo que quiero imprimir y la rutina se encarga del resto sin tener que entrar a la caja de dialogo del comando plot, pero tengo un problema, en la ofician tenemos 2 impresoras en red, entonces cuando probé la primer rutina que se llama I1 que funciona a la perfección, per el CAD como que guardo la dirección de la impresora que se utiliza en esa rutina I1, y cuando quiero utilizar la otra rutina que I2 para utilizar la otra impresora, no funciona porque el CAD solo reconoce la primera direccion que utilize y no la que puse en la rutina I2. Entonces no se si habrá alguna forma de resetear eso y que el reconozca cualquiera de las 2 direcciones conde se encuentran las impresoras.

Adjunto los códigos de las rutinas.

Código:
(DEFUN c:I1 ()
  (SETQ OS (GETVAR "OSMODE"))
  (SETVAR "OSMODE" 0)
  (SETQ pt1 (GETPOINT "\nIndique pimera esquina de la ventana: "))
  (SETQ pt3 (GETCORNER pt1 "\nIndique segunda esquina de la ventana: "))
  (VL-CMDF "-plot"    "y"     ""
   "\\PRINTSERVER-PC\EPSON L1300 Series\\"
   ""    "11 x 17 pulg."  "Millimeters"
   "Landscape"    "N"     "Window"
   pt1    pt3     "fit"
   "center"    "Y"     "CARBON_reducido"
   "Y"    "N"     "N"
   "N"    "N"     "N"
   "Y"
  )
  (SETVAR "OSMODE" OS)
  (PRINC)
)




Código:
(DEFUN c:I2 ()
  (SETQ OS (GETVAR "OSMODE"))
  (SETVAR "OSMODE" 0)
  (SETQ pt1 (GETPOINT "\nIndique pimera esquina de la ventana: "))
  (SETQ pt3 (GETCORNER pt1 "\nIndique segunda esquina de la ventana: "))
  (VL-CMDF "-plot"    "y"     ""
   "\\PRINTSERVER-PC2\EPSON T1110 Series\\"
   ""    "US B (11 x 17 pulg.)"  "Millimeters"
   "Landscape"    "N"     "Window"
   pt1    pt3     "fit"
   "center"    "Y"     "CARBON_reducido"
   "Y"    "N"     "N"
   "N"    "N"     "N"
   "Y"
  )
  (SETVAR "OSMODE" OS)
  (PRINC)
)

Alejandros85

Mensajes : 7
Fecha de inscripción : 05/04/2016
Edad : 31
Localización : San Jose, Costa Rica

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas con impresoras en red

Mensaje por amc.dicsac el Vie Jun 10, 2016 9:37 pm

Hola que tal, encontre un lisp del maestro Marco Jacinto que lo modifique según mi interes.

Fijate bien las contrabarras para que no tengas problemas   \\\\PC-11\\EPSON L300 Series


\\\\PC-11  --->> Nombre de usuario en el cual esta la impresora conectada via red
\\EPSON L300 Series  ----> Nombre de la impresora


Código:

(defun c:Plot2 (/ p1 p2 Impresora Tamañopapel Escala ArchCTB)
(setvar "cmdecho" 0)
(setq p1 (getpoint "\n>> Selecciona pto1: ")
      (initget 32)
      p2 (getcorner p1 "\n>> Selecciona pto2: ")
      Impresora   "\\\\PC-11\\EPSON L300 Series" ;_Pon Aqui tu impresora
      Tamañopapel "A4 (210 x 297 mm)"            ;_La medida del papel
      Escala      "fit"                          ;_La escala de impresion
      ArchCTB     "2-DEUSTUA-REVISION 50.ctb"    ;_El nombre del archivo CTB para la impresion
  )
    (command "_.-Plot"
             "_Y"           ; Detailed plot configuration? Yes/No]
             "Model"        ;_Enter a layout name or [?] :
             Impresora      ;_Enter an output device name or [?] <>:
             TamañoPapel    ;_Enter paper size or [?] :
            "_Millimeters"  ;_Enter paper units :
            "_Landscape"    ;_Enter drawing orientation [Portrait/Landscape]:
            "_No"           ;_Plot upside down? [Yes/No] :
            "_Window"       ;_Enter plot area
             p1             ; _Enter lower left corner of window  ll
             p2             ; _Enter upper right corner of window ur
             Escala         ; _Enter plot scale ( Millimeters=Drawing)
            "_Center"       ;_Enter plot offset (x,y) or [Center]
            "_Y"            ;_Plot with plot styles? [Yes/No] :
             ArchCTB        ; _Enter plot style table name or
            "_Y"            ;_Plot with lineweights? [Yes/No] :
            "_N"            ; _Enter shade plot setting
            "_N"            ;_Write the plot to a file [Yes/No] :
            "_N"            ;_Save changes to page setup [Yes/No]
            "_Y"
    )
  (setvar "cmdecho" 1)
  (princ)
)

Espero te sea util saludos..


Última edición por amc.dicsac el Vie Jun 17, 2016 2:35 am, editado 1 vez
avatar
amc.dicsac

Mensajes : 76
Fecha de inscripción : 17/03/2016
Edad : 26
Localización : Lima - Perú

Ver perfil de usuario http://axprogramlisp.blogspot.pe/

Volver arriba Ir abajo

Re: Problemas con impresoras en red

Mensaje por Alejandros85 el Vie Jun 10, 2016 11:22 pm

Muchas gracias amc.dicsac, si me funciono, guarde el nombre de la impresora en una variable como en tu ejemplo, solo que no tuve que ponerle el mismo número de contra barras porque no me funcionaba, no se porque. Le deje el mismo nombre solo que guardado en una variable y ahora si funciona.

Saludos y bendiciones.

Alejandros85

Mensajes : 7
Fecha de inscripción : 05/04/2016
Edad : 31
Localización : San Jose, Costa Rica

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas con impresoras en red

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.